Testing이나 Unstable은 가끔 다수의 패키지 의존성이 뒤틀리는
문제가 나타날 수 있으므로 삽질을 원하지 않는다면 그냥 Stable을 쓰자.
(+ 배포판 업그레이드는 공식 배포판인 stable만 가능)

1) 기존 배포판을 가장 최신 상태로 업글

# aptitude update
#
aptitude upgrade
#
aptitude dist-upgrade

혹시나 의존성 에러는 없는지 다시 한번 확인

# dpkg -C
# apt-mark showhold


2) 소스 리스트 수정. contrib, non-free 추가

** 기존 배포판을 가장 최신 패키지로 업글한 후에 리스트를 수정할 것 **

deb http://ftp.jp.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://ftp.jp.debian.org/debian/ stretch-updates main contrib non-free

 ㄴ jessie에서 stertch로 올리는 경우를 가정

3) 다시 한번 패키지 및 배포판 업그레이드
# aptitude update

# aptitude upgrade
# aptitude dist-upgrade


Posted by 猫한 보스코

댓글을 달아 주세요

http://www.epsxe.com/


퀵 세이브/로드 지원, 스캔라인 필터, 쉐이더 지원으로

쾌적하게 파이널 판타지 7 한글판을 플레이. 사양이 높으면 철권도 가능.

 

bios 디렉터리에 바이오스 파일을 넣어준다. 
 ㄴscph1001가 적당 


[내장 플러그인에서 셰이더 사용법]

2.0.1 기준; 기본으로 깔려 있는 ePSXe GPU core 2.0.0 비디오 플러그인을 선택.

설정창에서 Shader effects를 "99: Custom"을 선택하고 옆의 "..." 버튼을 눌러

사용하려는 셰이더를 선택.

ex) 카툰 셰이더 사용 시 D:\Game\ePSXe202-1\shaders\Cartoon_shader_II\ 폴더를 지정

 

*** 2.0 버전부터는 기본 내장 플러그인 사용하면 됨 ***

Video 플러그인 : Pete's D3D Driver 1.77 (2013-12)
 ㄴ 1.9 버전 이하에서만 외부 플러그인이 필요

  ㄴ 최신 버전에서도 Pete GL2 GPU 플러그인이 더 낫더라 (2017.12)

Sound 플러그인 : ePSXe SPU core 1.9.0 (기본 내장)

 

[Pete's OpenGL2 GPU core 2.0.0 설정법]

Internal X/Y resolution이 바로 업스케일 옵션임. High는 x2, Very High는 x4.

Very High로 하면 폴리곤이 더 세밀, 선명해지나 2D 배경과의 조화를 생각하여

High로 놨음. 취향 따라 Very High도 무방.


대부분의 값들은 Standard면 OK. 텍스처도 ePSXe 에뮬이 PC 게임마냥 플스 내부의

텍스처 설정을 건드리는 게 아니므로 None으로 두자. 나는 화질에 영향을 주는 것을

Internal X/Y resolution과 Shader effects만 건드렸다.

(Screen filtering 옵션도 있지만 뿌옇게 흐려지는 단점 때문에 비추)


Shader 파일은 2xGLSL shader를 골랐는데 SaL GLSL shader도 괜찮았음. 혹은

guest(r)'s shader 모음 중에서 AA Shader도 써볼 만하고 의외로 Shader effects를

그냥 "1 Fullscreen smoothing"으로 놓는 것도 나쁘지 않았음.


MDEC filter는 버그인지 화면 절반만 필터가 걸리는 문제 때문에 꺼버렸고

Special game fixes는 파판 7,8 옵션을 켜줬음. 스캔라인은 개인 취향.


[ 비디오 플러그인 설정 ] << 구형 D3d 플러그인 설정법이니 참고만 할 것

 

** Off-Screen drawing을 체크해야 파판7 전투 시 메뉴를 볼 수 있다

** 파판7을 위해 Special games fixes > Adjust framebuffer access : O

      (ㄴ ePSXe 1.9에선 필요 없더라)

** 사일런트 힐1에서 하얀 네모가 보이는 걸 막기 위해 Mask bit : O

** 내장 리미터가 있으므로 플러그인의 FPS limit도 필요없다
 

Posted by 猫한 보스코
TAG 에뮬

댓글을 달아 주세요

대부분의 내용은 이 동영상을 참고했음.


버추얼 사운드 캔버스의 후속으로 사운드 캔버스 VA가 나와주어

윈도우 8.1 이후 버전에서도 롤랜드 MIDI 사운드를 이용할 수 있게 되었다.

도스박스와도 연동 가능함. 가격은 125 $.


%%% 윈도우 8.1 기준 %%%


사운드 캔버스 VA는 가상 악기 플러그인일 뿐(VST) 일반적인 사용을 위해선 몇 가지 다른

프로그램이 필요하다.

a. loopMIDI : 가상 미디 포트 역할을 담당

b. savihost : 가상 악기 호스트. 사운드 캔버스 VA.dll 파일과 이름을 같게 바꾸고 실행하면

사운드 캔버스 VA를 띄울 수 있다.

c. 기본 미디 매퍼 : MS 기본 미디 장치를 사운드 캔버스 VA로 잡기 위해 필요


loopMIDI는 윈도우 시작 시 자동실행하도록 하는 게 편리하다. loopback 미디 포트의

이름을 적당히 적어서 추가한다.


제어판에서 기본 미디 mapper를 지정하던 항목이 사라졌기에 Coolsoft 사의

MIDIMapper 프로그램을 사용하자. 다운로드를 위해선 게시판 회원 가입이 필요하다.

 ㄴ http://coolsoft.altervista.org/en/forum/thread/427

기본 미디 장치로 loopMIDI에서 등록한 미디 포트를 선택한다. 이제  MS 미디어 플레이어에서도

사운드 캔버스 VA를 통한 재생이 가능하다. 단, 도스박스와 미디어 플레이어를

동시에 실행하면 악기 배열이 흐트러지므로 주의.


savihost.exe 파일을 사운드 캔버스 VA가 설치된 폴더로 옮겨 파일명을

Sound Canvas VA.exe로 변경한다. 그리고 시작!

Devices > MIDI 메뉴에서 Input Port 1에다 loopMIDI에서 등록한 포트를 지정한다.

사운드 캔버스 메인 화면 오른쪽 하단의 OPTION 버튼을 통해 SYSTEM 항목에서

사운드 캔버스 모델을 바꿔볼 수 있고, Activation과 Buy Now 항목에선 체험판을

구매하여 정식 등록할 수 있다.

 

도스박스를 실행하고 "mixer /listmidi" 명령으로 loopMIDI의 포트가 몇 번째 장치인지

확인한 후 dosbox.conf 파일의 midiconfig= 항목에 적어넣자. mididevice는 default로

하거나 win32. 게임 셋업 시 General MIDI를 선택하면 되고 이제부터 dosbox의 미디 볼륨

조절도 사운드 캔버스 VA를 통해 할 수 있다.







Posted by 猫한 보스코

댓글을 달아 주세요